Jump to content


Photo

[EM4] Los Angeles Mod bugs, issues and problems


  • Please log in to reply
934 replies to this topic

#1 Hoppah

Hoppah

    Boss cat

  • Administrators
  • 3,804 posts
  • Gender:Male
  • Location:Special Needs Department

Posted 25 September 2009 - 07:42 PM

Any problem related to the Los Angeles Mod can be posted in this topic. You can also post possible bugs here.
List with all reported and confirmed bugs below:

LA mod v1.9 bugs:
- Mission 7: Cannot unload Boat Transporter at the water (more information here)
- New map: Pathfinding problems on the bridge
- New map: No hostages during hostage situations
- Stolen vehicle cannot be towed after using the chase command on it

Multiplayer:
- Using the chase command officers are as soon they get out of the car invisible to the joiners.

-------------------------------------------------------------------------------------

Patch 3

* DOWNLOAD *
Includes all previous patches
Size: 1,78 mb

Patch 3 fixes the following bugs:
- Fixed issue with the chase command
- Fixed missing LA Mod missions from the mission list
- Fixed issue with the command for rapid undeployment
- Added traffic lights to four intersections on the new map
- Both fire stations spawn with full staffing now

Patch 2 (included) fixes the following bugs:
- Fixed intersection where traffic got stuck on the new map
- Fixed physics of the pawn shop building on the new map
- Fixed several issues with the chase command
- Fixed rain which never stopped in freeplay mode
- Fixed diver not being available in mission 7
- Fixed HAZMAT squad parking problems at FS2

Patch 1 (included) fixes the following bugs:
- Fixed missing building on the new map
- Fixed physics of Wal-Mart building
- Added icons to the minimap of the new map
- Added traffic lights to three intersections on the new map
- Trailer of the tiller is invulerable to fire now

This patch updates the mod to: v1.9.3

-------------------------------------------------------------------------------------

Unfixable bugs:
- Mission 8: Convoy can get redirected by vehicles with directional lights on.
- The trailer of tiller does not have physics when it is not installed. This prevents the trailer from getting stuck.
- The tiller cannot be installed at windows.
- The fireman on the ladder sometimes floats in the air.
- The trailer logic might be buggy and/or slow on older computers and during online play.
- MP5, M4a1 and PSG-1 fire through objects.
- Mission 2: Canister sometimes can't be closed (restarting the game will fix it)
- Mission 3: Bomb Squad cannot pick up the briefcase (restarting the game will fix it)
- Sometimes, the wye cannot be picked up, the fireman disappears and nothing else happens.

Strange occasions: (often reported as bugs, but cannot or won't be changed)
- Vehicles on patrol ignore traffic lights
- The watercannon of parked fire engines in one of the fire stations shoots through the roof of the fire station when a fire is in its vicinity.
- When personnel of the third parked ambulance (fire station 1) exits the vehicle they sometimes appear outside of the fire station.

-------------------------------------------------------------------------------------

Hoppah
Forrest-Gump-Wave-on-Boat.gif
Chief of Staff Special Needs Dept.

#2 Guest_M1n1d0u_*

Guest_M1n1d0u_*
  • Guests

Posted 26 September 2009 - 01:15 AM

Hi , i'm new , awesome work about 1.9 but when i playing in freeplay games i don't have the chase script , is it a bug ?

#3 Pearl71

Pearl71

    Captain

  • Members
  • 161 posts
  • Gender:Male
  • Location:Lock Haven, PA
  • Interests:firefighting, ems, rapelling, airsoft, computers, tv, college football, fishing, hunting.

Posted 26 September 2009 - 01:34 AM

Missing Building on freeplay map.

Attached Images

  • LAMODV1.9_BUG.jpg

Posted Image
Posted Image

#4 Guest_cbh84_*

Guest_cbh84_*
  • Guests

Posted 26 September 2009 - 01:37 AM

I don't know if its a bug or you wanted it this way but there are no building icons on the mini map
Also firefighters can walk through the back bay doors at fire station 1 when they are closed

One more thing I think the building some people are missing (the movie theater) is a Deluxe building but I may be wrong

#5 Newfoundking

Newfoundking

    Multiplayer Liaison

  • Moderator
  • 6,536 posts
  • Gender:Male
  • Location:Newfoundland

Posted 26 September 2009 - 02:25 AM

These are more than likely Deluxe buildings that were not included in the mod package, therefore when non deluxe players try to play, they are missing... The quick fix for this is either for Hoppah to release a patch with them a) included in the patch, so it'll work, or b) removed from the map, for the non deluxe players... And if you really want, you can go into the editor, and replace them yourself for now ;)

Wanna play multiplayer without any of the commitment? Emergency Planet hosts casual multiplayer to all its members! Contact me for more information

 

Executive Director: EMP Gulag

 

Do you have a warning that you want to go away, or are you facing another punishment you don't want? Contact me for the NEW alternative!


#6 Guest_Dave_*

Guest_Dave_*
  • Guests

Posted 26 September 2009 - 07:29 AM

Ok, great additions, I love the tiller. I also like the new buildings and American cars. It makes it very realistic. A few bugs I have noticed so far. The FBI still doesn't work in Multiplayer, when using the chase command the officers sometimes become invisible and non-selectable after getting out of the car, and they will just stop traffic around them. that's all I have found so far. Great Job though. You always do a great job

#7 Guest_Bl00d_B0urne_*

Guest_Bl00d_B0urne_*
  • Guests

Posted 26 September 2009 - 07:32 AM

Two Small bugs i found:

First: Since tiller trailer has no physics, cars can drive through it, even when trying to block road.

http://i35.tinypic.com/2af0sv9.jpg

and

Bucket on Tower seems to be sitting back.
http://i37.tinypic.com/2epq9e8.jpg

Other than those two atm, great Mod.


oh and btw, i tried to replace the Tiller in the firestationstart script file, but when freeplay starts up, only the Tiller Cabin is in the station.

#8 Guest_cbh84_*

Guest_cbh84_*
  • Guests

Posted 26 September 2009 - 07:39 AM

If the tiller gets near any fires the trailer gets heavily damaged

#9 usmc123

usmc123

    Captain

  • Members
  • 225 posts
  • Gender:Male
  • Location:Tucson, Arizona

Posted 26 September 2009 - 07:50 AM

just played and im missing a model file which looks like theres meant to be a stadium there and when theres a aronist the fire cant be put out :(

here is a picture



That, and the forum child watch van seems to get stuck in traffic often. Other vans seem to as well. Other than that, great job Hoppah.
Religion is a brilliant institution, but only because it's a placebo for cosmic ignorance.

#10 festival

festival

    Lieutenant

  • Members
  • 80 posts
  • Gender:Male
  • Location:Likely to be at work in the Control Room

Posted 26 September 2009 - 07:52 AM

The water at top of new 1.9 freeplay map is completely static (cant show in a screenshot) and not ripply as it should be. Also, no station icons on minimap as in 1.8, maybe not bug but an omission/forgotten?
Posted Image
Inshore Team Member

Click linked banner for mod thread!!
A part-time part-timer

#11 Hoppah

Hoppah

    Boss cat

  • Administrators
  • 3,804 posts
  • Gender:Male
  • Location:Special Needs Department

Posted 26 September 2009 - 08:16 AM

Hi , i'm new , awesome work about 1.9 but when i playing in freeplay games i don't have the chase script , is it a bug ?

Look closer, it's there. The command has the same icon as the Follow command of the police helicopter.

Missing Building on freeplay map.

Will be fixed in a patch today.

there are no building icons on the mini map

It's not a bug, but I forgot to add the icons on the mini map.

The FBI still doesn't work in Multiplayer, when using the chase command the officers sometimes become invisible and non-selectable after getting out of the car

The FBI vehicles should be available in multiplayer now. You just need to buy them yet (the big + button). I'm aware of the chase command bug, a similar thing happens to a few other commands. Fixing the multiplayer bugs is not really high on my to-do list now. Thanks for mentioning them though.

Two Small bugs i found:

First: Since tiller trailer has no physics, cars can drive through it, even when trying to block road.

I have mentiond the tiller bugs a couple of times before the release of v1.9. It's one of the many reasons I didn't want to make a tiller in the first place. I can't fix that, but did add all known tiller issues to the first post. You need to adjust the script to spawn the trailer as well and attach it to the tiller. Did the bug with aerial ladder (the tower) happened more than once?

You need to adjust the start script to spawn a tiller and attach it to the trailer.

If the tiller gets near any fires the trailer gets heavily damaged

Will (probably) be fixed in a patch.

That, and the forum child watch van seems to get stuck in traffic often. Other vans seem to as well. Other than that, great job Hoppah.

Please take some pictures of the points where they get stuck, but I might take a look at the physics of the vans.

The water at top of new 1.9 freeplay map is completely static (cant show in a screenshot) and not ripply as it should be.

It's not static here. I just checked it. Do you have 911:FR and do more people have this problem? I think it's a 911:FR related problem.


I will release a patch today which fixes most of the bugs mentioned above. :)

Hoppah
Forrest-Gump-Wave-on-Boat.gif
Chief of Staff Special Needs Dept.

#12 Pearl71

Pearl71

    Captain

  • Members
  • 161 posts
  • Gender:Male
  • Location:Lock Haven, PA
  • Interests:firefighting, ems, rapelling, airsoft, computers, tv, college football, fishing, hunting.

Posted 26 September 2009 - 08:21 AM

also ive noticed some missing civilian vehicles in the city driving around...
Posted Image
Posted Image

#13 mutu

mutu

    Captain

  • Members
  • 215 posts
  • Gender:Male
  • Location:Norway

Posted 26 September 2009 - 08:25 AM

At some points patrol cars causes traffic jam. One point is in the upper left corner. Another bug is when you try to redirect a vehicle it stops, and you can't do anything with it except frok shooting it. But a great mod! :cheers:
Posted Image


If we let things terrify us, life will not be worth living.

#14 Hoppah

Hoppah

    Boss cat

  • Administrators
  • 3,804 posts
  • Gender:Male
  • Location:Special Needs Department

Posted 26 September 2009 - 08:29 AM

also ive noticed some missing civilian vehicles in the city driving around...


Unfortunately, I cannot check that out myself. Can you start the editor, load the mod, then the map and see if you can find a few of these missing vehicles? (they get replaced by that 'missing object' box). If you do, make a screenshot of that and post it here. Then I can load the map myself and can find out what vehicle is missing.
Forrest-Gump-Wave-on-Boat.gif
Chief of Staff Special Needs Dept.

#15 Pearl71

Pearl71

    Captain

  • Members
  • 161 posts
  • Gender:Male
  • Location:Lock Haven, PA
  • Interests:firefighting, ems, rapelling, airsoft, computers, tv, college football, fishing, hunting.

Posted 26 September 2009 - 08:41 AM

Unfortunately, I cannot check that out myself. Can you start the editor, load the mod, then the map and see if you can find a few of these missing vehicles? (they get replaced by that 'missing object' box). If you do, make a screenshot of that and post it here. Then I can load the map myself and can find out what vehicle is missing.



ill get right on that for ya, it just seemed weird to me, ill have an answer asap
Posted Image
Posted Image

#16 Guest_M1n1d0u_*

Guest_M1n1d0u_*
  • Guests

Posted 26 September 2009 - 08:48 AM

i try with all police vehicule and i don't have it in freeplay (i have it in campaign) thanks for all (sorry i'm french)

#17 Pearl71

Pearl71

    Captain

  • Members
  • 161 posts
  • Gender:Male
  • Location:Lock Haven, PA
  • Interests:firefighting, ems, rapelling, airsoft, computers, tv, college football, fishing, hunting.

Posted 26 September 2009 - 08:54 AM

ok i believe it was the crown vic. taxi but i tried to trouble shoot myself, reinstalled the mod, and their back.... sorry my bad
Posted Image
Posted Image

#18 em4fun

em4fun

    Battalion Chief

  • Members
  • 505 posts
  • Gender:Male
  • Location:NETHERLANDS

Posted 26 September 2009 - 11:21 AM

a trafic path bug: it happend a few times,

bug.jpg

#19 szron

szron

    Captain

  • Members
  • 174 posts
  • Gender:Male
  • Location:Westland, Michigan
  • Interests:Emergency Services, Scuba Diving, Audio engineering, Scanning, Ham Radio

Posted 26 September 2009 - 02:56 PM

I have static water bug too!
(EM 4 Standart v.)

There is only one patrol path and all my units are patroling in column.

There are a lot of jams when patroling viechle meets heavy traffic.

And when my tiller trailer starts burning (YAY :D) i can't extinguish it. I mean when it started to burn i moved away main truck from tiller and left trailer. You cant do anything with it.

Hope you understand ;D

So, what is it the fire fighters do? Do they wait a block away before going to the station to get the truck? Nope. 10 or 12 guys go into the Station, put their gear on, and 6 of them jump in the Pump. The rest, they stay in the building in case they need the Rescue. So, Pump 1 responds from 119 Bertie St to 119 Bertie St, but, they have to follow protocol. So, they drive around they block, and stage at the corner, waiting for police to clear the building they just left.

x]

#20 Guest_M1n1d0u_*

Guest_M1n1d0u_*
  • Guests

Posted 26 September 2009 - 03:05 PM

Hi everyone
I Found 2 bugs
- in Comercial center (wall mart) the vehicules can go across the bulding
- circulation accident near the LA river the vehicules spawn and imidiatly explodes

thanks for all !

Minidou